Hey all! Followed the AWS EC2 instructions to get ...
# ask-community-for-troubleshooting
Hey all! Followed the AWS EC2 instructions to get Airbyte running and run into the following issue when running
docker-compose up -d
Copy code
ERROR: Couldn't connect to Docker daemon at <http+docker://localhost> - is it running?

If it's at a non-standard location, specify the URL with the DOCKER_HOST environment variable.
I spotted from searching slack that a previous user had forgotten to run
sudo usermod -aG docker $USER
but I’ve done that and it still doesn’t work. Anyone come across this before?
in the terminal docker-compose will only run if the daemon is running, you can configure the machine to run dockerd automatically after booting up in sysinitd
Did that, same error
Running under sudo gives
Copy code
INFO[2021-08-12T15:55:39.138481642Z] Starting up
failed to start daemon: pid file found, ensure docker is not running or delete /var/run/docker.pid`
docker ps
gives this if it helps
Copy code
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get "<http://%2Fvar%2Frun%2Fdocker.sock/v1.24/containers/json>": dial unix /var/run/docker.sock: connect: permission denied
Ah logging out and back in did it
That’s my mistake whoops
👍 2