https://linen.dev logo
#troubleshooting
Title
# troubleshooting
s

Serhii Сheredko

02/08/2022, 11:32 AM
Hi! Is this your first time deploying Airbyte: Yes OS Version / Instance: Local Airbyte in a Docker container, my machine is on Ubuntu 20.04 Deployment: Docker Airbyte Version: 0.35.23-alpha Source name/version: MongoDB v4.2.13 Destination name/version: - Step: Setting new source Description: I'm trying to configure new source, which is a MongoDB replica set on MongoDB Atlas Cloud. I chose "MongoDB Instance type" option to be "Replica Set" and pointed out my replicas along with the name. But I'm getting the "SSL peer shut down incorrectly" error. I thought it might be an issue with IP whitelisting, but my IP is whitelisted on the Cloud and I can connect to it locally. If I change it, I'll get another error("Connect timed out"). Hence, it seems it's something to do with SSL, not whitelisting.
Attaching logs(the replicas urls are amended)
n

Noah Kawasaki

02/08/2022, 1:41 PM
There was actually another recent post about Replicas not being able to be connected to, I think you might have a similar issue. Airbytes mongodb replica connections dont support SSL if I remember correctly. Do your replicas require SSL connections?
https://github.com/airbytehq/airbyte/issues/9871 https://github.com/airbytehq/airbyte/issues/9843 Actually the other mongo issue was related to a custom SSL cert, though I think you might be running into a similar issue with respect to TLS somehow
s

Serhii Сheredko

02/08/2022, 2:02 PM
Yes, the replicas require SSL. Thanks, I'll take a look!
n

Noah Kawasaki

02/08/2022, 2:09 PM
Okay, in checking the mongo code it doesnt seem like there is any configuration to make airbyte use SSL for replicas. Is that what you see on the UI? You might just need to file a feature request for SSL/TLS config support for Replicas
s

Serhii Сheredko

02/08/2022, 6:13 PM
The UI says
{com.mongodb.MongoSocketWriteException: Exception sending message}, caused by {javax.net.ssl.SSLHandshakeException: Remote host terminated the handshake}, caused by {java.io.EOFException: SSL peer shut down incorrectly}}
And there's an info message under the options select:
For MongoDB Atlas and Replica Set TLS connection is used by default.
So maybe a TLS version mismatch? Or maybe the replica doesn't require TLS(I connect to it w/o TLS though), but Airbytes forces it, can that be an issue? I've tried to connect to one instance of the replica by choosing the option "MongoDB Atlas"(near the "MongoDB Instance Type" select) and pointing out the Cluster URL, but I'm getting:
srvResolutionException=com.mongodb.MongoConfigurationException: Unable to look up SRV record for host my-atlas-host.com, servers=[]
n

Noah Kawasaki

02/09/2022, 2:15 PM
Hm, when I was reading the mongo connector code I didnt see anywhere using TLS for the replica but its possible I missed it. The docs might be wrong, or maybe I am.
Oh, yeah, it could totally be a TLS version mismatch:
Either way, I do believe its possible that the issue is not being able to configure the connection in Airbyte with more flexibility.
a

ahsen m

03/23/2022, 8:15 PM
@Noah Kawasaki i am seeing this mongodb problem with tls issues. Is it possible to make tls option in airbyte optional ?
m

Marcos Marx (Airbyte)

03/24/2022, 7:04 PM
tls option
today is not possible using the standard connector