# help


02/01/2022, 5:06 AM
I run into this issue:
Copy code
gitpod /workspace/platform/services/website $ supabase start
Error: Error starting database: Password for user postgres: 
psql: error: connection to server at "localhost" (::1), port 5432 failed: FATAL:  password authentication failed for user "postgres"
This is a clean environment with the
CLI installed and happens when I follow the local development docs ( I run this in a Gitpod ( developer environment and it likely has to do with that because it works locally. If anyone has managed to run Supabase on Gitpod, please let me know I'd love to learn what you did.


02/01/2022, 3:11 PM
Hi Buddy, do you have a example project setup that I could clone on gitpod to try and help with this. I've been so bad I should have tried gitpod by now seeing that you are always mentioning it on Twitter and I've seen many people singing its praise.


02/01/2022, 6:22 PM
👋 I have one, but the code is not pushed yet. Let me do that and send you the link a bit later today. Contact me if you'd like a Gitpod intro and skip reading the docs 😊.
I'm back :). I pulled it into its own repo to eliminate any other factors. You can check and click the "Open in Gitpod" button in the PR description. When the developer environment starts, you see it automatically runs
supabase start
. Let it pull the Docker images and you'll see the error pop up when it tries to start up.
Take this with a grain of salt, but I wonder if that
in is an issue. For Docker container to Docker container communication among microservices, I previously had to use
instead. Again, I can't prove it but given everything else is default settings, this may be worth checking.
Thanks a lot for your help, I'll keep you posted on anything else I find.
One more observation: The error mentions port
, which isn't being served. However, I see port
open (notice the extra
I can connect from the host to the db via port
Copy code
gitpod /workspace/gitpod-supabase (configure-supabase) $ psql --username postgres --host localhost --port 54322
Password for user postgres: 
psql (14.1 (Ubuntu 14.1-2.pgdg20.04+1))
Type "help" for help.