https://supabase.com/ logo
#help
Title
# help
b

birdiewd

12/25/2021, 1:36 AM
Hello all. I'm having some issues with getting my twitter authentication working. The user can see my app listed in their profile as having access, but supabase provides the following error on redirect:
?error=server_error&error_description=Error+getting+user+email+from+external+provider
Here are my settings in twitters dev portal:
Here is the tutorial I am following:
t

tourdownunder

12/25/2021, 11:24 PM
I noticed you are trying locally. I'm not sure if mine has ever worked locally. Only when I deployed. I also see the following when using it local.
Copy code
sh
  [10:20:51] 200 ─ 0.67ms ─ /?error=server_error&error_description=Request+token+doesn%27t+match+token+in+callback
  [10:21:59] 200 ─ 2.80ms ─ /
To fix it locally I need to set the
HOST=127.0.0.1
as twitter doesn't like localhost
Copy code
sh
HOST=127.0.0.1 npm run start
I also had to add the following Authentication -> Configuration -> Settings -> Additional Redirect URLs -> http://127.0.0.1:5000/
b

birdiewd

12/26/2021, 5:03 AM
Thank you for this info. I also deployed this to vercel and this is still happening.
g

geordi

12/27/2021, 5:16 PM
This is happening for me also
m

magma

12/30/2021, 7:41 AM
has anyone resolved it?
it's happening to me as well
Apparently, twitter API won't let you read email if you have only got standard access. You need elevated access for supabase auth to work.
so upgrade your account to elevated.