https://supabase.com/ logo
hello everyone, I have just cloned git to run supa...
# help
r
hello everyone, I have just cloned git to run supabase locally and I have a problem with db.. exec /usr/local/bin/docker-entrypoint.sh: exec format error I'm trying to run it inside a Ampere in OCI any relation? or maybe some real issue with the docker db image?
n
Hello @Robson! This thread has been automatically created from your message in #843999948717555735 a few seconds ago. We have already mentioned the @User so that they can see your message and help you as soon as possible! Want to unsubscribe from this thread? Right-click the thread in Discord (or use the ``...`` menu) and select "Leave Thread" to unsubscribe from future updates. Want to change the title? Use the ``/title`` command! We have solved your problem? Click the button below to archive it.
r
yeah, I suspect it is the platform, I'm not sure because since docker is running I thought it should be independent.. idk maybe someone know this.. f.y.i.
Copy code
/usr/local/bin/docker-entrypoint.sh: exec format error

Linux codi 5.4.17-2136.309.4.el8uek.aarch64 #2 SMP Tue Jun 28 17:38:28 PDT 2022 aarch64 aarch64 aarch64 GNU/Linux
definitely a platform issue, wondering how I could rebuild supabase/postgres based on postgres aarch64
suspect it is the postgis, tried to build my own image to run init scripts had to use postgis/postgis to install the extensions and got the same issue when trying to start it up
n
Ampere in OCI
As I understand, the Postgres db is built for Amd not ARM. I also had this issue when trying to build it on OCI. I recall reading an Issue about this. You could try to search about Raspberry pi and it should show some similar results.
3 Views