03/15/2022, 2:50 AM
Okay, I think I am the source of this issue and I am trying to work my way back out of it. In the process of moving to a new machine, I have managed to get Dendron to kick out errors stating that there are no vaults to be found both on the old machine and the new. I installed vscode and Deondron, then cloned my repo onto the new system. All files were there as expected, but no tree view or search option. The original .workspace files were kept outside the repo. I tried pulling them from the google drive folder where I kept them and somehow in the process ended up with some changes that sent the same error (no vaults found) to my original workspace/machine. I'm feeling a bit stuck now with a very full vault that isn't functional anywhere. Not sure how to proceed.


03/15/2022, 1:05 PM
@User can you describe your vaults on disk? eg. - {vault-name1} - {vault-name2} ...
at this point, it might be easiest to 1. create a new workspace using "dendron initialize workspace" 2. add your vaults to it (dendron vault add)


03/15/2022, 1:21 PM
After some more reading through the documentation last night I tend to agree that just creating a new workspace and adding the vault may be the simplest solution. Just not sure where I went sideways on this. It was a local vault - {vault} That was managed with git/GitHub. I had the .workspace file outside of the repo and I think that was the beginning of the problem as I just cloned the repo into a new workspace on the new machine. I’m assuming at this point that some of the dendron management files are kept in the same place as the .workspace file(?) so the creation of a new workspace for a local vault broke things. I’ll work the new workspace later today. It will give me a chance to do some cleanup on a few other things anyway. Thanks for the quick reply.
I did an add vault with the remote repo this evening and managed to get things working on the new machine. Looks like I have some learning to do on how to best sync a vault, but that is for another day after the current project ends! Thanks for the help