discussion
  • Keming

    Keming

    11/04/2022, 2:31 AM
    Nope. I don't have macOS. But 0.4.1 works on my Linux. Can you check if you can find the binary file under
    PosixPath('/usr/local/lib/python3.10/site-packages/mosec/bin/mosec')
    ?
  • d

    delon

    11/04/2022, 2:34 AM
    hmm i am running in docker linux ..... there is no folder /usr/local/lib/python3.10/site-packages/mosec/bin/mosec ... let me figure it out the permission ...
  • z

    zichen

    11/04/2022, 2:36 AM
    let me check on Mac
  • d

    delon

    11/04/2022, 2:37 AM
    hmm there is no binary .. similar error for both macos monterey and linux docker ....
  • Keming

    Keming

    11/04/2022, 2:38 AM
    0.4.1?
  • d

    delon

    11/04/2022, 2:39 AM
    yea 0.4.1 .. btw
    pip install mosec==0.4.3
    is not available yet ...
  • z

    zichen

    11/04/2022, 2:39 AM
    message has been deleted
  • z

    zichen

    11/04/2022, 2:40 AM
    what's your python version?
  • d

    delon

    11/04/2022, 2:40 AM
    i see i see ... i tried from 3.7 to 3.10 ... using venv ...
  • d

    delon

    11/04/2022, 2:41 AM
    hmm what is ur mac os version ?
  • z

    zichen

    11/04/2022, 2:41 AM
    could you
    cat /usr/local/lib/python3.10/site-packages/mosec/_version.py
  • d

    delon

    11/04/2022, 2:42 AM
    message has been deleted
  • z

    zichen

    11/04/2022, 2:42 AM
    Im using 11.7, an old one
  • z

    zichen

    11/04/2022, 2:44 AM
    message has been deleted
  • Keming

    Keming

    11/04/2022, 2:45 AM
    I guess it's related to python and pip
  • d

    delon

    11/04/2022, 2:45 AM
    got it got it
  • z

    zichen

    11/04/2022, 2:45 AM
    should be available if py version is above 3.6
  • Keming

    Keming

    11/04/2022, 2:45 AM
    try
    which python && python --version && python -m pip install mosec==0.4.3
  • d

    delon

    11/04/2022, 2:45 AM
    message has been deleted
  • d

    delon

    11/04/2022, 2:46 AM
    i used
    FROM python:3.10
    image btw ...
  • d

    delon

    11/04/2022, 2:46 AM
    let me try with other machine ... thanks ...
  • z

    zichen

    11/04/2022, 2:46 AM
    how about specifying the index-url
  • z

    zichen

    11/04/2022, 2:46 AM
    not sure if the default one is changed..
  • d

    delon

    11/04/2022, 2:48 AM
    message has been deleted
  • d

    delon

    11/04/2022, 2:49 AM
    actually for good measure, i clone and checkout v0.4.3 and
    pip install -e .
    and got same error as above ...
  • Keming

    Keming

    11/04/2022, 2:50 AM
    you should use
    make dev
  • Keming

    Keming

    11/04/2022, 2:50 AM
    but it requires rust
  • d

    delon

    11/04/2022, 2:50 AM
    ok let me try ...
  • Keming

    Keming

    11/04/2022, 2:50 AM
    curl --proto '=https' --tlsv1.2 -sSf https://sh.rustup.rs | sh -s -- -y
  • d

    delon

    11/04/2022, 3:09 AM
    ok i guess is specific to macos ... i tried other machine and it can work without any issues ... will figure it out ... thanks @Keming @zichen