# questions


04/03/2022, 7:45 PM
Hi all, dropping my question here rather than opening a github issue as it may simply be user error. I am having difficulty launching the publish dev server from within vscode. When I launch the dev server via the "Dendron: Publish Dev" action, I first get prompted to select "Use default" or "Use config", I have tried both. After that I am prompted to "Skip" or "Don't skip" the build process. I assume that I should not skip the build process, however I have tried both. Regardless of the options I choose, I get the following error: "siteUrl is undefined. See for more details" I have the following set in my dendron.yml publishing: siteUrl: "" However, I am able to build and host the dev via the CLI $ npx dendron publish build $ npx dendron publish dev So it's just within vscode itself that I cannot build. Is there something else that I am missing?


04/04/2022, 5:42 AM
@User Can you share the content of
, and also the content of the log right after the error happens? You can run
Dendron:Dev Open Logs
to open the log right after it happens. Also, it would be great if you can create a github issue if you don't mind. It would be easier to track than Discord conversations 🙂


04/04/2022, 11:35 PM
Thank you for the reply. I have opened issue #2685